Glassfish 2.x et OpenJDK

Et maintenant, un article sur le serveur d’application Glassfish et OpenJDK, étant donné que j’ai rencontré un problème dont je n’ai trouvé la solution nulle part ailleurs.

En essayant d’installer Glassfish 2.2 sous Linux, j’ai rencontré cette erreur :

/opt/glassfish/setup-cluster.xml:160: Glassfish requires JDK 1.5 or higher, you have java version "1.7.0_03-icedtea"

Cette erreur apparaît au moment d’exécuter cette commande :

sudo ant -f setup-cluster.xml

Après un peu trop d’heures de recherches, j’ai vu que dans le xml qu’il vérifiait mal la version de Java, étant donné que j’ai la version 1.7 du JDK. J’ai rajouté la ligne pour la version 1.7 dans la fichier xml:

<condition property="java.version.acceptable"> 
  <or>
    <contains string="${targeted.java.version}" substring="1.5"/>
    <contains string="${targeted.java.version}" substring="1.6"/>
    <contains string="${targeted.java.version}" substring="1.7"/>
  </or> 
</condition>

Je suis arrivé à cette solution en lisant cet article : http://www.ensode.net/java_fedora_8_icedtea.html et apparemment, glassfish-installer-v2-b58g ne fonctionne pas avec OpenJDK même avec cette astuce, cependant j’ai testé avec glassfish 2.1.1_b31g-1 (le dernier dans les dépos AUR d’ArchLinux) et aucun problème jusqu’à présent.

PS: pour ceux sous Archlinux, il est possible que la commande ant ne fonctionne même pas, elle se situe dans /usr/share/java/apache-ant/bin/ .

2 réflexions au sujet de « Glassfish 2.x et OpenJDK »

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *